Blog

Read our news, ideas & product updates here.

Blog Releases 

OpenProject 7.4.4 released

Sharing is caring!

We released OpenProject 7.4.4. The release contains several bug fixes. We recommend the update to the current version.

  • Work package modification for regular users on MySQL-based instances (#27237)
  • Child work packages were not deleted when the parent element is deleted (#27280)
  • The fuzzy project autocompletion has been corrected to provide better matching when a substring is matched (#27447)
  • The GitHub integration plugin did not properly receive events due to a naming clash (#27448)
  • Creating new wiki pages from a wiki link (e.g,  [[ Wiki page ]] ) now retains the correct title instead of the generated URL slug (#27462)
  • A subsequent search for documents in the global search disabled the documents search checkbox (#27479)
  • The reset button for RSS tokens generated a new API token instead (#27498)
  • Wiki start pages (titled Wiki) could not be renamed back if the name was changed at one point (#27576)

 

Changes

  • Meetings plugin: The close button of the show page now requires a confirmation before closing (#27336)
  • The restriction to create a time entry with at maximum 1000 hours on a single work package has been lifted (#27457)

4 responses to “OpenProject 7.4.4 released

  1. Mauro Miotello says:

    Trying to update i’ve this message:
    openproject is already the newest version (7.4.3-1522745840.a5123b7c.xenial)
    7.4.4 is only enterprise ?

    1. Oliver Günther says:

      Hi Mauro,

      no we do not have separate releases for CE and EE versions. 7.4.4 should be available for Ubuntu 16.04:

      Here’s a log of the packaging build:
      https://packager.io/gh/opf/openproject-ce/builds/787/logs/ubuntu-16.04

      Best,
      Oliver

  2. Nick says:

    What about bionic?

    The following packages have unmet dependencies.
    openproject : Depends: libreadline6 but it is not installable
    Depends: libevent-2.0-5 but it is not installable
    Depends: libevent-core-2.0-5 but it is not installable
    Depends: libevent-extra-2.0-5 but it is not installable

    1. Oliver Günther says:

      HI Nick,

      very good point. Now that 18.04. has been out for a few weeks, we will deprecate 14.04. and introduce support for 18.04. in the near future. If you’re interested, follows this ticket to get notified of changes: https://community.openproject.com/wp/27799

      Best,
      Oliver

Leave a Reply

Your email address will not be published. Required fields are marked *