Upgrading to the Current Version Questions

Frequently asked upgrading to the current version questions.

How do I upgrade my old OpenProject version to the current one?

Follow the upgrade guide  to update to the current version of OpenProject .

I get an error during bower install. What can I do?

We heard that bower install can fail, if your server is behind a firewall which does not allow git:// URLs. The error looks like this:
bower openproject-ui_components#with-bower ECMDERR Failed to execute "git ls-remote --tags --heads git://github.com/opf/openproject-ui_components.git", exit code of #128

Additional error details:
fatal: unable to connect to github.com:
github.com[0: 192.30.252.131]: errno=Connection refused

npm ERR! OpenProject@0.1.0 postinstall: `./node_modules/bower/bin/bower install`
The solution is to configure git to use https:// URLs instead of git:// URLs lke this:
git config --global url."https://".insteadOf git://